Bump up Glib dependency to 2.66.0

Required by : !236
2 jobs for !245 with glib-2.66 in 7 minutes and 39 seconds (queued for 3 seconds)
latest merge request