Commit fed83cde authored by Benedikt Meurer's avatar Benedikt Meurer

2006-04-16 Benedikt Meurer <benny@xfce.org>

	* === Released 0.3.1.6beta1 ===
	* NEWS, configure.in.in: Bump version.
	* configure.in.in: Depend on Xfce 4.2.2 or above.
	* Makefile.am, exo.spec.in, configure.in.in: Readd fixed exo.spec.in
	  file for RPM building.




(Old svn revision: 20999)
parent e2d8fdf7
2006-04-16 Benedikt Meurer <benny@xfce.org>
* === Released 0.3.1.6beta1 ===
* NEWS, configure.in.in: Bump version.
* configure.in.in: Depend on Xfce 4.2.2 or above.
* Makefile.am, exo.spec.in, configure.in.in: Readd fixed exo.spec.in
file for RPM building.
2006-04-16 Benedikt Meurer <benny@xfce.org>
* po/libexo-0.3.pot, po/*.po: Updated.
......
......@@ -36,15 +36,19 @@ EXTRA_DIST = \
README \
THANKS \
TODO \
exo.spec.in \
intltool-extract.in \
intltool-merge.in \
intltool-update.in
DISTCLEANFILES = \
exo.spec \
intltool-extract \
intltool-merge \
intltool-update
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-xsltproc
DISTCHECK_CONFIGURE_FLAGS = \
--enable-gtk-doc \
--enable-xsltproc
# vi:set ts=8 sw=8 noet ai nocindent:
0.3.1.5svn
==========
0.3.1.6beta1
============
- Imported the "Xfce Preferred Applications" framework, which allows users to
select their preferred applications (i.e. web browser, mail reader, terminal
emulator) using a nice graphical interface, rather than having to figure out
......
......@@ -9,19 +9,19 @@ dnl
dnl ***************************
dnl *** Version information ***
dnl ***************************
m4_define([libexo_verinfo], [2:0:2])
m4_define([libexo_verinfo], [3:0:3])
m4_define([libexo_version_major], [0])
m4_define([libexo_version_minor], [3])
m4_define([libexo_version_micro], [1])
m4_define([libexo_version_nano], [5])
m4_define([libexo_version_nano], [6])
m4_define([libexo_version_build], [r@REVISION@])
m4_define([libexo_version_tag], [svn])
m4_define([libexo_version], [libexo_version_major().libexo_version_minor().libexo_version_micro()ifelse(libexo_version_nano(), [], [], [.libexo_version_nano()])ifelse(libexo_version_tag(), [], [], [libexo_version_tag()-libexo_version_build()])])
m4_define([libexo_version_tag], [beta1])
m4_define([libexo_version], [libexo_version_major().libexo_version_minor().libexo_version_micro()ifelse(libexo_version_nano(), [], [], [.libexo_version_nano()])ifelse(libexo_version_tag(), [svn], [libexo_version_tag()-libexo_version_build()], [libexo_version_tag()])])
dnl ********************************************
dnl *** Full debug support for SVN snapshots ***
dnl ********************************************
m4_define([libexo_debug_default], [ifelse(libexo_version_tag(), [], [minimum], [full])])
m4_define([libexo_debug_default], [ifelse(libexo_version_tag(), [svn], [full], [minimum])])
dnl ***************************
dnl *** Initialize autoconf ***
......@@ -106,12 +106,12 @@ dnl *** Check for required packages ***
dnl ***********************************
XDT_CHECK_PACKAGE([GLIB], [glib-2.0], [2.6.4])
XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.6.0])
XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.2.1])
XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.2.2])
dnl *********************************************
dnl *** Check for xfce-mcs-manager (optional) ***
dnl *********************************************
XDT_CHECK_OPTIONAL_PACKAGE([XFCE_MCS_MANAGER], [xfce-mcs-manager], [4.2.1],
XDT_CHECK_OPTIONAL_PACKAGE([XFCE_MCS_MANAGER], [xfce-mcs-manager], [4.2.2],
[mcs-plugin], [xfce-mcs-manager], [yes])
dnl *************************
......@@ -257,6 +257,7 @@ docs/manual/C/exo-preferred-applications.xml
docs/manual/C/images/Makefile
docs/reference/Makefile
docs/reference/version.xml
exo.spec
exo/Makefile
exo/exo-0.3.pc
exo/exo-config.h
......
Summary: Application library for the Xfce desktop environment
Name: @PACKAGE_TARNAME@@LIBEXO_VERSION_API@
Version: @PACKAGE_VERSION@
Release: 1
License: LGPL
URL: http://libexo.os-cillation.com/
Source0: %{name}-%{version}.tar.gz
Group: Development/Libraries
BuildRoot: %{_tmppath}/%{name}-root
Requires: gtk2 >= @GTK_REQUIRED_VERSION@
Requires: libxfce4util >= @LIBXFCE4UTIL_REQUIRED_VERSION@
BuildRequires: gtk2-devel >= @GTK_REQUIRED_VERSION@
BuildRequires: libxfce4util-devel >= @LIBXFCE4UTIL_REQUIRED_VERSION@
BuildRequires: xfce-mcs-manager >= @XFCE_MCS_MANAGER_REQUIRED_VERSION@
BuildRequires: gtk-doc
%description
Extension library for Xfce, targeted at application development.
%package devel
Summary: Development files for the exo library
Group: Development/Libraries
Requires: @PACKAGE_TARNAME@@LIBEXO_VERSION_API@ >= @PACKAGE_VERSION@
%description devel
Static libraries and header files for the exo library.
%prep
%setup -q
%build
%configure --enable-final --enable-gtk-doc --disable-python --enable-xfce-mcs-manager --enable-xsltproc
make
%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir}
mv $RPM_BUILD_ROOT/%{_datadir}/gtk-doc/html/exo $RPM_BUILD_ROOT/%{_datadir}/gtk-doc/html/exo-@LIBEXO_VERSION_API@
%clean
rm -rf $RPM_BUILD_ROOT
%post
/sbin/ldconfig
touch --no-create %{_datadir}/icons/hicolor || :
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
fi
%postun
/sbin/ldconfig
touch --no-create %{_datadir}/icons/hicolor || :
if [ -x %{_bindir}/gtk-update-icon-cache ]; then
%{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
fi
%files
%defattr(-,root,root)
%{_bindir}/exo-open
%{_bindir}/exo-preferred-applications
%{_datadir}/applications
%{_datadir}/icons
%{_datadir}/locale
%{_datadir}/xfce4
%{_libdir}/lib*.so.*
%{_libdir}/xfce4/mcs-plugins/*
%{_libexecdir}
%{_mandir}/man1/exo-open.*
%{_sysconfdir}
%files devel
%defattr(-, root, root)
%{_bindir}/exo-csource
%{_datadir}/gtk-doc
%{_includedir}
%{_libdir}/lib*.so
%{_libdir}/lib*a
%{_libdir}/pkgconfig/*.pc
%{_mandir}/man1/exo-csource.*
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment