Commit cdd0747c authored by Romain Bouvier's avatar Romain Bouvier
Browse files

Bug #16717: Move from exo-csource to xdt-csource

- exo-csource is deprecated and moved to xdt-csource
- Bump minimal xdt version
parent 5b3801cd
#!/bin/sh
#
# $Id$
#
# Copyright (c) 2002-2009
# Copyright (c) 2002-2020
# The Xfce development team. All rights reserved.
#
# Written for Xfce by Benedikt Meurer <benny@xfce.org>
# and Brian Tarricone <brian@tarricone.org>.
#
export XDT_AUTOGEN_REQUIRED_VERSION="4.7.0"
export XDT_AUTOGEN_REQUIRED_VERSION="4.14.0"
(type xdt-autogen) >/dev/null 2>&1 || {
cat >&2 <<EOF
autogen.sh: You don't seem to have the Xfce development tools (at least
version $XDT_REQURED_VERSION) installed on your system, which
are required to build this software.
autogen.sh: You don't seem to have the Xfce development tools installed on your system,
which are required to build this software.
Please install the xfce4-dev-tools package first; it is available
from https://www.xfce.org/.
from your distribution or https://www.xfce.org/.
EOF
exit 1
}
......
......@@ -46,7 +46,7 @@ BUILT_SOURCES = \
SUFFIXES: .ui
%-ui.h: $(srcdir)/%-ui.glade Makefile
$(AM_V_GEN) exo-csource --static --name=`basename $< .glade | $(SED) -e 's/-/_/g'` $< >$@
$(AM_V_GEN) xdt-csource --static --name=`basename $< .glade | $(SED) -e 's/-/_/g'` $< >$@
endif
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment