Commit ef8c84ba authored by Erkki Moorits's avatar Erkki Moorits Committed by Gaël Bonithon
Browse files

Added libxfce4util check.

As building Orage depends on libxfce4util we need to verify its
precence and set appropriate CFLAGS and LIBS variables in Makefile.
parent 912a6e2d
Pipeline #16064 passed with stages
in 1 minute and 43 seconds
......@@ -91,6 +91,7 @@ AC_DEFINE(GLIB_VERSION_MAX_ALLOWED, GLIB_VERSION_2_52, Warn when using post 2_52
AC_DEFINE(GLIB_VERSION_MIN_REQUIRED, GLIB_VERSION_2_52, Don't warn about post 2_52 deprecations)
XDT_CHECK_PACKAGE([GLIB], [glib-2.0], [glib_minimum_version])
XDT_CHECK_PACKAGE([LIBGTK], [gtk+-3.0], [gtk_minimum_version])
XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [xfce_minimum_version])
dnl ************************************************
dnl *** Optional support for Xfce Panel ***
......
......@@ -20,12 +20,14 @@ globaltime_CPPFLAGS = \
globaltime_CFLAGS = \
$(LIBGTK_CFLAGS) \
$(LIBX11_CFLAGS) \
$(LIBXFCE4UI_CFLAGS)
$(LIBXFCE4UI_CFLAGS) \
$(LIBXFCE4UTIL_CFLAGS)
globaltime_LDADD = \
$(LIBGTK_LIBS) \
$(LIBX11_LIBS) \
$(LIBXFCE4UI_LIBS) \
$(LIBXFCE4UI_LIBS) \
$(LIBXFCE4UTIL_LIBS) \
$(INTLLIBS) \
$(top_builddir)/src/liborage.la
......
......@@ -52,11 +52,13 @@ orage_CPPFLAGS = \
orage_CFLAGS = \
$(LIBGTK_CFLAGS) \
$(LIBX11_CFLAGS)
$(LIBX11_CFLAGS) \
$(LIBXFCE4UTIL_CFLAGS)
orage_LDADD = \
$(LIBGTK_LIBS) \
$(LIBX11_LIBS) \
$(LIBXFCE4UTIL_LIBS) \
-lm \
$(INTLLIBS) \
liborage.la
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment