Warn about GLib functions newer than the checked GLib version

This patch enables GLib deprecation warnings in all XFCE apps and libraries
containing function calls such as XDT_CHECK_PACKAGE([GLIB], [glib-2.0], [2.56.0])
in their configure.ac.in files in the following way:

  AC_DEFINE(GLIB_VERSION_MAX_ALLOWED, GLIB_VERSION_2_56, Prevent post 2_56 APIs)
  AC_DEFINE(GLIB_VERSION_MIN_REQUIRED, GLIB_VERSION_2_56, Ignore post 2_56 APIs)

The 3rd argument passed to XDT_CHECK_PACKAGE([GLIB], ...) selects the
GLib API version. So XDT_CHECK_PACKAGE([GLIB], [glib-2.0], [2.44.0])
would add:

  AC_DEFINE(GLIB_VERSION_MAX_ALLOWED, GLIB_VERSION_2_44, Prevent post 2_44 APIs)
  AC_DEFINE(GLIB_VERSION_MIN_REQUIRED, GLIB_VERSION_2_44, Ignore post 2_44 APIs)

The enabled warnings can be overridden by the app or library by using
the two AC_DEFINEs after calling XDT_CHECK_PACKAGE([GLIB], ...).

Something like XDT_CHECK_PACKAGE([GLIB], [glib-2.0], [2.45.8]) will make
the XFCE app or library uncompilable because 2.45 isn't a stable GLib release.

See also: apps/xfce4-notifyd#34

Signed-off-by: Jan Ziak <0xe2.0x9a.0x9b@gmail.com>
2 jobs for !35 with warn_2_56 in 38 seconds (queued for 1 second)
latest detached
Status Name Job ID Coverage
  Build
passed build #9654

00:00:16

 
  Distcheck
passed distcheck #9655

00:00:22