Commit 3b21f3a0 authored by Romain Bouvier's avatar Romain Bouvier

Bug #16717: Move from exo-csource to xdt-csource

- exo-csource is deprecated and moved to xdt-csource
- Bump minimal xdt version
- Clean autohell variables: we already require automake 1.11+ from
  configure.ac, not need to add useless AUTOMAKE_OPTION
parent a5f65bfb
# This file will be processed with automake-1.7 to create Makefile.in
AUTOMAKE_OPTIONS = 1.7
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS} ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
NULL = NULL =
......
#!/bin/sh #!/bin/sh
# #
# Copyright (c) 2002-2009 The Xfce development team. All rights reserved. # Copyright (c) 2002-2020 The Xfce development team. All rights reserved.
# #
# This library is free software; you can redistribute it and/or modify it # This library is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by the Free # under the terms of the GNU General Public License as published by the Free
...@@ -23,17 +23,16 @@ ...@@ -23,17 +23,16 @@
(type xdt-autogen) >/dev/null 2>&1 || { (type xdt-autogen) >/dev/null 2>&1 || {
cat >&2 <<EOF cat >&2 <<EOF
autogen.sh: You don't seem to have the Xfce development tools (at least autogen.sh: You don't seem to have the Xfce development tools installed on your system,
version $XDT_REQUIRED_VERSION) installed on your system, which which are required to build this software.
are required to build this software.
Please install the xfce4-dev-tools package first; it is available Please install the xfce4-dev-tools package first; it is available
from http://www.xfce.org/. from your distribution or https://www.xfce.org/.
EOF EOF
exit 1 exit 1
} }
test -d m4 || mkdir m4 test -d m4 || mkdir m4
XDT_AUTOGEN_REQUIRED_VERSION="4.7.2" exec xdt-autogen "$@" XDT_AUTOGEN_REQUIRED_VERSION="4.14.0" exec xdt-autogen "$@"
# vi:set ts=2 sw=2 et ai: # vi:set ts=2 sw=2 et ai:
## We require new-style dependency handling.
AUTOMAKE_OPTIONS = 1.7
NULL = NULL =
AM_CPPFLAGS = \ AM_CPPFLAGS = \
......
## We require new-style dependency handling.
AUTOMAKE_OPTIONS = 1.7
NULL = NULL =
saverdir = $(libexecdir)/xfce4-screensaver saverdir = $(libexecdir)/xfce4-screensaver
...@@ -249,13 +246,13 @@ xfce4_screensaver_preferences_LDADD = \ ...@@ -249,13 +246,13 @@ xfce4_screensaver_preferences_LDADD = \
if MAINTAINER_MODE if MAINTAINER_MODE
xfce4-screensaver-dialog-css.h: $(srcdir)/xfce4-screensaver-dialog.css Makefile xfce4-screensaver-dialog-css.h: $(srcdir)/xfce4-screensaver-dialog.css Makefile
$(AM_V_GEN) exo-csource --static --name=xfce4_screensaver_dialog_css $< >$@ $(AM_V_GEN) xdt-csource --static --name=xfce4_screensaver_dialog_css $< >$@
xfce4-screensaver-dialog-ui.h: $(srcdir)/xfce4-screensaver-dialog.ui Makefile xfce4-screensaver-dialog-ui.h: $(srcdir)/xfce4-screensaver-dialog.ui Makefile
$(AM_V_GEN) exo-csource --static --strip-comments --strip-content --name=xfce4_screensaver_dialog_ui $< >$@ $(AM_V_GEN) xdt-csource --static --strip-comments --strip-content --name=xfce4_screensaver_dialog_ui $< >$@
xfce4-screensaver-preferences-ui.h: $(srcdir)/xfce4-screensaver-preferences.ui Makefile xfce4-screensaver-preferences-ui.h: $(srcdir)/xfce4-screensaver-preferences.ui Makefile
$(AM_V_GEN) exo-csource --static --strip-comments --strip-content --name=xfce4_screensaver_preferences_ui $< >$@ $(AM_V_GEN) xdt-csource --static --strip-comments --strip-content --name=xfce4_screensaver_preferences_ui $< >$@
DISTCLEANFILES = \ DISTCLEANFILES = \
$(xfce4_screensaver_dialog_built_sources) \ $(xfce4_screensaver_dialog_built_sources) \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment